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1. Cel ćwiczenia

• Zapoznanie się z podstawowymi możliwościami modułu DSC w zakresie tworzenia rozpro-
szonych systemów pomiarowo-sterujących.

• Utworzenie aplikacji HMI z zastosowaniem oprogramowania LabVIEW i modułu DSC.

• Nabycie umiejętności dodawania trendów rzeczywistych oraz zarządzania alarmami z za-
stosowaniem oprogramowania LabVIEW i modułu DSC.

2. Wprowadzenie

Moduł DSC (ang. Datalogging and Supervisory Control Module) poszerza graficzne środowi-
sko projektowania LabVIEW o dodatkową funkcjonalność związaną z błyskawicznym projekto-
waniem rozproszonych systemów pomiarowo-sterujących i aplikacji monitoringu o dużej liczbie
kanałów wejścia/wyjścia. Moduł DSC posługuje się zmiennymi wspólnymi (ang. Shared Varia-
bles) programu LabVIEW. DSC wykorzystuje zmienne wspólne do dostępu i przekazywania da-
nych pomiędzy różnymi przyrządami wirtualnymi (VI) w ramach jednego projektu LabVIEW
lub poprzez sieć. Zmienna wspólna może reprezentować pojedynczą wartość lub punkt I/O (wej-
ścia/wyjścia). Za pomocą modułu DSC możliwe jest automatyczne logowanie danych, dodawanie
alarmów, skal i zabezpieczeń do zmiennej wspólnej oraz jej programowa konfiguracja.

Moduł DSC dostarcza narzędzi do wyświetlania trendów rzeczywistych i historycznych, zwięk-
szania bezpieczeństwa paneli czołowych tworzonych przyrządów wirtualnych oraz tworzenia ser-
werów I/O użytkownika. Możliwy jest odczyt i zapis danych z i do połączeń OPC, sterowników
PLC (np. protokół MODBUS), systemów EPICS (ang. Experimental Physics and Industrial Con-
trol System), serwerów I/O w warstwie klienta i serwera a także serwerów I/O stworzonych przez
użytkownika. DSC dostarcza rozwiązań dla sterowania nadrzędnego szerokiej gamy systemów
rozproszonych z użyciem graficznego środowiska programowania LabVIEW.
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3. Przebieg ćwiczenia

3.1. Budowa aplikacji programu LabVIEW z użyciem modułu DSC

3.1.1. Aplikacja HMI bez wsparcia modułu DSC

Dokumentacja modułu DSC zawiera wiele przykładów, które mogą być wykorzystane do
nauki różnych aspektów tego modułu i nauki tworzenia aplikacji. Przedstawiony przykład apli-
kacji zostanie wykorzystany w dalszej części ćwiczenia. Aby uruchomić przykład DSC Tank
Simulator należy wykonać następujące kroki:

1. Wybrać menu Help»Find Examples aby wyświetlić narzędzie wyszukiwania przykładów
NI Example Finder. Wybrać Directory Structure w zakładce Browse. Przejść do folderu
lvdsc\Getting Started\Tank Simulator i otworzyć DSC Tank Simulator
VI. Przyrząd wirtualny symuluje proces napełniania zbiornika wodą. Panel przyrządu wir-
tualnego przedstawiono na rys. 1.

Rys. 1. Panel przyrządu wirtualnego (VI) do wizualizacji procesu napełniania zbiornika

2. Uruchomić VI.

3. Poruszając suwakiem Input Flow Rate zmienić objętościowe natężenie przepływu (w ga-
lonach na minutę) na dopływie do zbiornika. Zaobserwować, że możliwe jest dokładne za-
dawanie wartości natężenia za pomocą kontrolki numerycznej.

4. Poruszając suwakiem Tank Valve zmienić natężenie przepływu na odpływie ze zbiornika
wyrażone w procentach natężenia na dopływie. Zaobserwować, że możliwe jest dokładne
zadawanie wartości natężenia za pomocą kontrolki numerycznej.

5. Zaobserwować zachowanie procesu dla różnych położeń suwaków.

6. Zatrzymać i zamknąć VI.

Zaprezentowany VI nie wykorzystuje możliwości modułu DSC. W kolejnym punkcie utwo-
rzona zostanie aplikacja wizualizacyjna korzystająca z przedstawionego VI i modułu DSC.
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3.1.2. Tworzenie biblioteki projektu

W tym punkcie zostanie utworzony nowy projekt programu LabVIEW oraz biblioteka projek-
tu. Projekt umożliwia zarządzanie zmiennymi wspólnymi, bibliotekami oraz VI z poziomu jed-
nego okna. Biblioteki projektu w programie LabVIEW są kolekcjami VI, definicji typów, plików
palet menu i innych plików, również innych bibliotek. Aby utworzyć bibliotekę projektu programu
LabVIEW należy wykonać następujące kroki:

1. Wybrać Create Project w oknie Getting Started lub menu File»Create Project.

2. Wybrać Blank Project a następnie Finish.

3. Z menu kontekstowego (kliknięcie prawym klawiszem myszy) węzła My Computer w oknie
Project Explorer wybrać New»Library.

4. Wybrać File»Save All. Pojawi się okno dialogowe Name the Project. Przejść na Pulpit
i utworzyć nowy folder (np. nazwisko osoby z grupy). Przejść do utworzonego folderu.

5. Wprowadzić Tank System w polu File Name i kliknąć OK. Pojawi się okno Name the
Library.

6. Wprowadzić Tank System IO Server w polu File Name i kliknąć OK.

Został utworzony nowy projekt programu LabVIEW o nazwie Tank System zawierający jedną
bibliotekę o nazwie Tank System IO Server. W kolejnym punkcie biblioteka Tank System IO
Serwer zostanie wykorzystana do utworzenia cyklicznego I/O serwera (serwera wejścia/wyjścia).

3.1.3. Tworzenie cyklicznego serwera I/O

Serwer I/O jest aplikacją stosowaną do komunikacji i zarządzania sprzętowymi urządzenia-
mi wejścia wyjścia, takimi jak sterowniki przemysłowe PLC, zdalne urządzenia wejścia/wyjścia,
zdalne mechanizmy zmiennych wspólnych oraz urządzenia cyfrowej akwizycji danych (ang. DAQ
plug-in devices). Serwery I/O zapisują i odczytują na żądanie elementy danych do i z urządzeń
wejścia/wyjścia. Moduł DCS pozwala na połączenie pomiędzy kompatybilnymi serwerami OPC
(ang. OLE for Process Control) oraz serwerami I/O wielu urządzeń wejścia/wyjścia różnych pro-
ducentów. Możliwe jest także utworzenie serwerów I/O użytkownika. W tym punkcie zostanie
utworzony cykliczny serwer I/O. Będzie on uruchomiony jako usługa i użyty do publikacji ele-
mentów danych w sieci za pośrednictwem protokołu subskrypcyjnego NI-PSP (ang. NI Publish-
Subscribe Protocol). Aby utworzyć cykliczny serwer I/O należy wykonać następujące kroki:

1. Z menu kontekstowego węzła biblioteki Tank System I/O Server.lvlib w oknie
Project Explorer wybrać New»I/O Server. Pojawi się okno Create New I/O Server.

2. Z listy I/O Server Type wybrać Custom VI – Periodic i kliknąć Continue. Pojawi się okno
Configure Custom VI – Periodic I/O Server.

3. Kliknąć New aby wyświetlić kolejny krok kreatora: Select VI.
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4. Wykonać następujące kroki, aby wybrać VI z p. 3.1.1, a następnie skonwertować wybrany
VI na cykliczny serwer I/O:

(a) Kliknąć przycisk Browse i wyszukać folder: C:\Program Files (x86)\National
Instruments\LabVIEW 2012\examples\lvdsc\Getting Started\Tank
Simulator

(b) Wybrać DSC Tank Simulator.

(c) Wybrać Next aby przejść do kolejnego kroku kreatora (Select Controls and Indica-
tors To Publish).

5. Aby opublikować wybrane elementy panelu czołowego jako zmienne wspólne należy wy-
konać następujące kroki:

(a) Odznaczyć pole wyboru Stop na liście Controls. Pozostałe kontrolki i wskaźniki pa-
nelu zostaną opublikowane.

(b) Kliknąć Next aby przejść do strony Select Method To Stop The Server.

6. Aby wybrać sposób zatrzymania VI należy wykonać następujące kroki:

(a) Wybrać Stop the following While Loops

(b) Zaznaczyć pole wyboru While Loop.
WSKAZÓWKA: Aby podświetlić na diagramie VI wybraną pętlę While należy klik-
nąć opcję View on Block Diagram. Opcja ta jest użyteczna, gdy wybieramy jedną
pętlę spośród wielu występujących na diagramie.

(c) Kliknąć Next aby przejść do kolejnego kroku kreatora (Configure Server Distribu-
tion Component).

7. Na stronie Configure Server Distribution Component należy pozostawić ustawienie do-
myślne i kliknąć Next. Strona ta pozwala wybrać co ma zostać zbudowane przez kreatora.

8. Moduł DSC wyświetli podsumowanie. Zawiera ono pliki, które zostaną utworzone przez
kreatora Custom VI-based Server – Periodic na podstawie ustawień wyspecyfikowanych
na stronie Server Distribution Component. Kliknąć Build. Kreator wyświetli okno dia-
logowe Build Status podczas tworzenia pliku szablonu VI, rejestrowania VI jako serwera
oraz dodawania wsparcia dla bibliotek DLL i VI.

9. Po utworzeniu przez kreatora cyklicznego serwera I/O, zostanie wyświetlone okno dialogo-
we Configure Custom VI – Periodic I/O Server. W oknie pojawi się nazwa serwera wraz
z elementami danych. Kliknąć OK. LabVIEW dodaje cykliczny serwer I/O do biblioteki
projektowej Tank System IO Server.

10. Rozwinąć bibliotekę Tank System IO Server.lvlib w oknie Project Explorer.
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11. Wybrać polecenie Rename z menu kontekstowego elementu Custom VI – Periodic1. Zmie-
nić nazwę cyklicznego serwera I/O na Tank1. Okno Project Explorer powinno wyglądać
następująco:

12. W oknie Project Explorer wybrać File»Save All. Polecenie zapisuje projekt, bibliotekę
oraz cykliczny serwer I/O.

3.1.4. Wdrażanie cyklicznego serwera I/O

Po utworzeniu serwera I/O należy go wdrożyć (ang. deploy) tak aby elementy danych serwe-
ra były dostępne dla innych VI i poprzez sieć. W tym podpunkcie programu ćwiczenia zostanie
wdrożony cykliczny serwer I/O utworzony w p. 3.1.3. Dodatkowo dane udostępniane przez serwer
będą przeglądane za pomocą NI Distributed System Manager.
WSKAZÓWKA: cykliczny serwer I/O działa w tle w sposób ciągły tak długo aż wdrażanie bi-
blioteki projektu, w której został on umieszczony, nie zostanie zatrzymane (ang. undeploy). Aby
wdrożyć cykliczny serwer I/O oraz przeglądać udostępniane dane należy wykonać następujące
kroki:

1. Wybrać polecenie Deploy All z menu kontekstowego węzła Tank System I/O Server.lvlib.

2. Gdy wdrażanie zakończy się zamknąć okno dialogowe Deployment Progress za pomocą
Close.

3. Wybrać Tools»Distributed System Manager. Pojawi się NI Distributed System Mana-
ger. Tank System I/O Server pojawi się w lewym panelu poniżej My System»localhost.

4. Rozwinąć węzeł Tank System IO Server»Tank1. Poniżej węzła Tank1 pojawią się kon-
trolki i wskaźniki serwera I/O. Ponieważ biblioteka projektu została wdrożona, serwer I/O
jest uruchomiony a każdy wskaźnik i kontrolka jest elementem danych wejścia/wyjścia.
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5. Kliknąć Input Flowrate [GPM] aby przejrzeć szczegóły elementu danych za pomocą Auto
View w prawym panelu.

6. W polu tekstowym New Value wprowadzić wartość 10 i zatwierdzić za pomocą Set. Zaob-
serwować, że wartości Tank Level [Gallons] oraz Tank Output Flowrate [GPM] zwięk-
szają się.

7. Zamknąć NI Distributed System Manager. Cykliczny serwer I/O pozostaje uruchomiony.

3.1.5. Tworzenie zmiennych wspólnych (ang. Shared Variables)

W tym punkcie do projektu zostanie dodana biblioteka Tank System Shared Variables. W ra-
mach biblioteki zostaną dodane sieciowe zmienne wspólne (ang. Network-Published Shared Va-
riables) reprezentujące elementy danych cyklicznego serwera I/O. Aby dodać bibliotekę Tank
System Shared Variables do projektu Tank System należy wykonać następujące kroki:

1. Wybrać New»Library z menu kontekstowego węzła My Computer w oknie Project Explo-
rer.

2. Aby wyświetlić okno dialogowe Create Bound Variables wybrać Create Bound Varia-
bles z menu kontekstowego węzła nowo utworzonej biblioteki.

3. W Browse Source wybrać Network Items.

4. Rozwinąć localhost»Tank System IO Server»Tank1 w drzewie Network Items. Poniżej
Tank1 pojawią się zmienne wspólne.

5. Wybrać wszystkie zmienne typu DBL i kliknąć Add aby dodać każdą ze zmiennych do listy
Added Variables.

6. Kliknąć OK. Okno dialogowe Create Bound Variables zostanie zamknięte. Zmienne wspól-
ne zostaną wyświetlone w oknie Multiple Variable Editor. Okno umożliwia jednoczesną
konfigurację dużej liczby zmiennych wspólnych. Możliwa jest także konfiguracja pojedyn-
czej zmiennej wspólnej za pomocą okna dialogowego Shared Variable Properties. W tym
celu należy kliknąć prawym przyciskiem myszy na istniejącej zmiennej w oknie Project
Explorer i wybrać Properties z menu kontekstowego.

7. Kliknąć Done aby zamknąć okno dialogowe Multiple Variable Editor.

8. Wybrać File»Save All i nazwać bibliotekę Tank System Shared Variables. LabVIEW po-
łączy zmienne wspólne z biblioteki Tank System Shared Variables z odpowiadającymi im
elementami publikowanymi w sieci.
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3.1.6. Konfiguracja logowania danych

Gdy zostanie włączone logowanie danych dla zmiennej wspólnej moduł DSC loguje dane
związane ze zmienną, włączając wartość zmiennej, znacznik czasowy, informacje na temat stanu
alarmowych oraz jakość wartości zmiennej. Moduł DSC może logować dane do bazy Citadel
lub innej wspieranej relacyjnej bazy danych. W tym podpunkcie zostanie włączone logowanie
zmiennej wspólnej Tank Level [Gallons] do bazy danych Citadel. Aby włączyć logowanie dla
wymienionej zmiennej należy wykonać następujące kroki:

1. Wybrać Multiple Variable Editor z menu kontekstowego węzła Tank System Shared Va-
riables.lvlib. Wyświetli się okno Multiple Variable Editor.

2. Zaznaczyć pole wyboru w komórce Logging:Enable dla zmiennej wspólnej Tank Le-
vel [Gallons]. Dodatkowe opcje pojawią się jako kolumny tabeli. Zaznaczyć pola wybo-
ru w komórkach: Logging:Alarms and Events i Logging:Data. Opcja Logging:Alarms
and Events włącza logowanie alarmów i zdarzeń. Opcja Logging:Data włącza logowanie
wartości historycznych dla zmiennej wspólnej.

3. Wprowadzić 0.1 w komórce Logging:Resolution dla zmiennej wspólnej Tank Level [Gal-
lons]. Wprowadzona wartość ustala rozdzielczość do jednego miejsca po przecinku, z jaką
będą logowane wartości zmiennej do bazy danych Citadel.

4. Pozostawić domyślną wartość równą 0.01w komórce Logging:Deadband zmiennej wspól-
nej Tank Level [Gallons]. Wartość ustala, że moduł DSC będzie logował wartość zmiennej
tylko wtedy, gdy nowa wartość różni się od poprzedniej o więcej niż 1%.

3.1.7. Konfiguracja alarmów

Wstąpienie alarmu jest związane z niestandardowym stanem zmiennej wspólnej, lub stanem
zdefiniowanym przez użytkownika. Najczęściej alarm występuje, gdy wartość zmiennej wychodzi
poza zakres ustalony przez limity alarmowe, lub zmienna posiada niewłaściwy status (spowodo-
wany np. błędem w komunikacji). W tym punkcie do zmiennej wspólnej Tank Level [Gallons]
zostanie dodany alarm. Aby dodać alarm do zmiennej należy wykonać następujące kroki:

1. Zaznaczyć pole wyboru w komórce Alarming:Enable dla zmiennej wspólnej Tank Level
[Gallons]. Dodatkowe opcje alarmów pojawią się jako kolumny tabeli.

2. Zaznaczyć pole wyboru w komórce Alarming:HI:Enable dla zmiennej wspólnej Tank
Level [Gallons]. Dodatkowe opcje alarmu typu HI pojawią się jako kolumny w tabeli. Za-
obserwować, że domyślna wartość alarmu typu HI, w komórce Alarming:HI:Limit jest
równa 75.

3. Kliknąć Done aby zaakceptować zmiany konfiguracji zmiennej wspólnej i zamknąć okno
Multiple Variable Editor.
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3.1.8. Włączanie logowania dla biblioteki projektu

Aby włączyć logowanie danych a także logowanie alarmów i zdarzeń dla biblioteki Tank
System Shared Variables.lvlib należy wykonać następujące kroki:

1. Wybrać Properties z menu kontekstowego węzła Tank System Shared Variables.lvlib
w oknie Project Explorer. Pojawi się okno dialogowe Project Library Properties.

2. Wybrać DSC Settings: Database z listy Category.

3. Opcje na stronie DSC Settings: Database powinny wyglądać następująco:

Opcja Enable Data Logging włącza logowanie danych dla biblioteki projektu. Użycie na-
zwy localhost zamiast nazwy komputera zmniejsza ilość czynności niezbędnych przy prze-
noszeniu projektu na inny komputer. Opcja Enable Alarms and Events Logging włącza
logowania alarmów i zdarzeń dla biblioteki projektu. Opcja Use the same database for
alarms and events zapewnia, że moduł DSC będzie logował alarmy i zdarzenia do tej samej
bazy danych co dane (wartości) zmiennej wspólnej. Możliwa jest zmiana w polu Database
Name w oknie dialogowym Project Library Properties tak, aby nazwa bazy była bardziej
opisowa i użyteczna.

4. Kliknąć OK. aby zamknąć okno dialogowe Project Library Properties.

5. Wybrać Deploy All z menu kontekstowego Tank System Shared Variables.lvlib w oknie
Project Explorer.

6. Kliknąć Close aby zamknąć okno dialogowe Deployment Progress po zakończeniu wdra-
żania.

7. Wybrać File»Save All w oknie Project Explorer aby zapisać projekt, bibliotekę projektu
oraz cykliczny serwer I/O.
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3.2. Tworzenie HMI

3.2.1. Budowa VI

Interfejs człowiek-maszyna (ang. HMI – Human-Machine Interface) jest interfejsem, przez
który operator oddziałuje na wizualizowany system oraz współdziała z zewnętrznym środowi-
skiem monitoringu i sterowania systemu. Do tworzenia aplikacji HMI (ekranów HMI) w progra-
mie LabVIEW używa się przyrządów wirtualnych (VI). Dodatkowo, moduł DSC dostarcza wła-
sne kontrolki, wskaźniki, VI oraz funkcje wspomagające proces tworzenia aplikacji HMI. W tym
punkcie zostanie zaprojektowany ekran HMI do wyświetlania elementów danych serwera I/O.
Ekran będzie umożliwiał monitoring i sterowanie elementami danych serwera za pośrednictwem
panelu programu LabVIEW. Aby utworzyć VI używający węzłów zmiennych wspólnych do wy-
świetlania danych z serwera I/O należy wykonać następujące kroki:

1. Wybrać New»VI z menu kontekstowego węzła My Computer w oknie Project Explorer.
Pojawi się nowy panel i diagram programu LabVIEW.

2. Wybrać zmienną wspólną Tank Level [Gallons] z biblioteki projektu Tank System Shared
Variables.lvlib w oknie Project Explorer i przeciągnąć tę zmienną na diagram. Zmienna
wspólna pojawi się jako węzeł zmiennej wspólnej. Domyślnie LabVIEW konfiguruje nowo
utworzone węzły zmiennych wspólnych jako węzły do odczytu.

3. Wybrać Create»Indicator z menu kontekstowego węzła Tank Level [Gallons] (podobnie
jak poprzednio dostęp do menu uzyskuje się po kliknięciu prawym przyciskiem myszy na
węźle).

4. Przejść na panel. Z menu kontekstowego wskaźnika Tank Level [Gallons] wybrać Re-
place»DSC Module»Vessels»Open Tank. Do zmiany rozmiaru wstawionego wskaźnika
(zbiornik) użyć narzędzia Positioning w palecie Tools.

5. Wybrać zmienną wspólną Input Flowrate [GPM] z biblioteki Tank System Shared Va-
riables.lvlib w oknie Project Explorer i przeciągnąć tę zmienną na diagram.

6. Wybrać Access Mode»Write menu kontekstowego węzła zmiennej wspólnej Input Flow-
rate [GPM] aby skonfigurować węzeł jako węzeł do zapisu.

7. Z menu kontekstowego węzła zmiennej wspólnej Input Flowrate [GPM] wybrać Cre-
ate»Control.

8. Przejść na panel. Z menu kontekstowego kontrolki Tank Level [Gallons] wybrać Repla-
ce»Num Ctrls»Pointer Slide.

9. Powtórzyć kroki 5–8 aby dodać zmienną wspólną Tank Valve [%] jako kontrolkę na panelu.

10. Otoczyć wszystkie elementy diagramu pętlą While. Proces zapisu i odczytu zmiennych
będzie przebiegał do zatrzymania przez użytkownika za pomocą przycisku Stop lub do
chwili wystąpienia błędu. Do wnętrza pętli While dodać funkcję Wait. Diagram i panel VI
powinny wyglądać następująco:
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11. Wybrać File»Save All i nazwać VI Tank System HMI.

12. Kliknąć Run aby uruchomić VI.

13. Kliknąć Close aby zamknąć okno Deployment Progress po zakończeniu wdrażania. Po-
czątkowo zbiornik może zapełniać się powoli. Zmienić położenie suwaków, aby zwiększyć
lub zmniejszyć prędkość zapełniania się zbiornika. Utworzony VI powinien działać tak sa-
mo, jak przykładowy VI z p. 3.1.1, niekorzystający z modułu DSC.

3.2.2. Podgląd danych w czasie rzeczywistym

Moduł DSC może być użyty do podglądu danych w czasie rzeczywistym. Real-Time Trend
Express VI służy do wyświetlania wartości zmiennych wspólnych na wykresie typu X-Y. W tym
punkcie do ekranu HMI zostanie dodana możliwość wyświetlania danych w czasie rzeczywistym.
Aby dodać Real-Time Trend Express VI do diagramu w celu przeglądania danych w czasie
rzeczywistym należy wykonać następujące kroki:

1. Wstawić Real-Time Trend Express VI z palety DSC Module na diagram VI Tank System
HMI. Wyświetli się okno dialogowe Configure Real-Time Trend.
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2. Rozwinąć węzeł biblioteki Tank System Shared Variables w drzewie Network Items aby
wyświetlić zmienne wspólne.

3. Wybrać zmienną Tank Level [Gallons] i wybrać Add w oknie dialogowym Configure
Real-Time Trend.

4. Kliknąć OK, aby zamknąć okno dialogowe Configure Real-Time Trend.

5. Przejść na panel. Dodać komponent Waveform Chart do panelu. Przejść na diagram. Po-
łączyć wyjście Trend Data bloku Real-Time Trend Express VI z blokiem Waveform
Chart.

6. Uruchomić VI. Wykres Waveform Chart wyświetla bieżącą wartość poziomu w zbiorni-
ku (zmienna wspólna Tank Level [Gallons]). Zmienić położenie suwaka Input Flowrate
[GPM]. Zaobserwować zmiany na wykresie w czasie rzeczywistym.

3.2.3. Przeglądanie alarmów z użyciem NI Distributed System Manager

Aby przeglądać alarmy z użyciem NI Distributed System Manager należy wykonać nastę-
pujące kroki:

1. Aby wyświetlić okno Distributed System Manager, wybrać Tools»Distributed System
Manager.

2. Rozwinąć węzeł biblioteki Tank System Shared Variables w lewym panelu, aby wyświe-
tlić zmienne wspólne.

3. Aby uzyskać informacje o alarmach rozwinąć Tank Level [Gallons]. Zaobserwować, że
wartość Tank Level [Gallons]»Alarms»HI»level jest równa 75. Wartość ta odpowiada
wartości domyślnej zdefiniowanej w p. 3.1.7. Dodatkowo folder Tank Level [Gallons]»Alarms»HI
zawiera wartości innych parametrów alarmu, zdefiniowanych wcześniej.

3.2.4. Monitorowanie stanu alarmów

Aby monitorować alarmy z użyciem widoku Alarms And Events w oknie Distributed Sys-
tem Manager należy wykonać następujące kroki:

1. Wybrać View»Alarms and Events aby wyświetlić widok Alarms and Events.

2. Kliknąć Select Processes aby wyświetlić okno dialogowe Select Processes.

3. Na liście Available Processes rozwinąć węzeł My Systems»localhost.

4. Wybrać Tank System Shared Variables i kliknąć Add aby dodać ten proces do listy Se-
lected Processes.

5. Kliknąć OK aby zamknąć okno dialogowe Select Processes. Zgodnie z parametrami zde-
finiowanymi w p. 3.1.7, gdy zmienna wspólna Tank Level [Gallons] osiągnie wartość 75
w widoku Alarms and Events pojawi się alarm.
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