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Ćwiczenie 6. Wprowadzenie do oprogramowania NI LabVIEW

Opracował: dr hab. inż. Sebastian Dudzik

1. Cel ćwiczenia

Celem ćwiczenia jest zapoznanie się z oprogramowaniem do akwizycji, wizualizacji i prze-
twarzania danych na przykładzie programu LabVIEW firmy National Instruments.

2. Wprowadzenie

Oprogramowanie LabVIEW jest środowiskiem projektowo-uruchomieniowym, przeznaczo-
nym do akwizycji i przetwarzania danych pomiarowych. Z powodzeniem może także służyć jako
program do wizualizacji i sterowania procesów technologicznych. W odróżnieniu od wielu języ-
ków programowania tworzenie aplikacji w LabVIEW polega na łączeniu odpowiednich symbo-
li graficznych zastępujących konkretne polecenia i funkcje (program stworzony za pomocą La-
bVIEW nazywany jest VI – wirtualny instrument). Taki sposób tworzenia programu jest bardziej
przejrzysty i bardzo ułatwia usuwanie błędów lub wprowadzanie późniejszych poprawek.

Po uruchomieniu LabVIEW na ekranie widzimy dwa okna: ekran panelu (rys. 1) oraz ekran
diagramu (rys. 2). Okno panelu zapewnia komunikację użytkownika z programem. Możemy na
nim umieszczać wszelkiego rodzaju przełączniki, przyciski, pokrętła, wskaźniki, okna graficzne,
wykresy itp., które będą wykorzystywane w tworzonej przez nas aplikacji. Ekran diagramu służy
do tworzenia struktury programu i implementacji algorytmów. Panel i diagram posiadają stałe
elementy są to: paski menu (1 na rys. 1 i rys. 2), pasek narzędzi (2 na rys. 1 i rys, 2 oraz rys. 5),
oraz obszar podglądu ikony/złącza (3 na rys. 1 i 2). Pasek menu panelu zawiera m.in. następujące
grupy poleceń:

• File – menu grupujące polecenia operacji na plikach i bibliotekach programu LabVIEW,

• Edit – polecenia kopiowania, wycinania i modyfikacji standardowych elementów,

• Operate – menu grupujące polecenia startu/stopu aplikacji użytkownika oraz ustawiania
wartości domyślnych elementów,

• Window – grupa poleceń wspierająca wyświetlanie okien diagramu, okien informacyjnych,
podglądu schowka i rozmieszczania obiektów na ekranie,

• Help – okno pomocy.
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Rys. 1. Okno panelu przykładowej aplikacji w środowisku LabVIEW: 1-pasek menu, 2-pasek narzędzi,
3-wygląd ikony/złącza, 4-pasek przewijania

Rys. 2. Okno diagramu przykładowej aplikacji w LabVIEW: 1–pasek menu, 2–pasek narzędzi, 3–wygląd
ikony/złącza, 4–pasek przewijania

Oprócz pasków menu w trakcie edycji programu w środowisku LabVIEW na ekranie pojawia-
ją się dwie palety: Functions (w trakcie edycji diagramu – rys. 3) oraz Controls (w trakcie edycji
panelu – rys. 4).
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Rys. 3. Paleta Functions

Rys. 4. Paleta Controls

Paleta Functions zawiera wszystkie dostępne polecenia (bloki) graficznego języka programo-
wania LabVIEW. Programowanie polega na wybieraniu odpowiednich bloków z menu Functions
i odpowiednim ich łączeniu za pomocą linii (połączeń). Połączenia te mają różny wygląd w zależ-
ności od przesyłanych informacji (np. cienka linia niebieska oznacza dane numeryczne – liczby
całkowite). Bloki funkcjonalne zostały podzielone na wiele grup, w ramach których zagnieżdżone
są podgrupy. Przykładowo na rys. 7 przedstawiono wygląd palety Controls po rozwinięciu grupy
Programming.

Pasek narzędzi (rys. 5) jest stałym elementem zarówno dla okna sterowania jak i okna diagra-
mu. Wygląd jego zmienia się w zależności od trybu pracy LabVIEW. Istnieją dwa tryby pracy:
tryb edycji, w którym możliwa jest edycja struktury programu i wyglądu panelu sterowania oraz
tryb pracy uruchomieniowy, w którym LabVIEW znajduje się po uruchomieniu aplikacji. W tym
trybie możliwe jest oglądanie diagramu bez możliwości zmian a aplikacją sterować można tylko
z panelu. Pasek narzędzi diagramu składa się z następujących ikon – przycisków (oznaczenia jak
na rys. 5):

1. Run – uruchomienie aplikacji.

2. Run Continuosly – uruchomienie aplikacji w trybie ciągłym.
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Rys. 5. Pasek narzędzi programu LabVIEW – tryb edycji

3. Abort Execution – zatrzymanie wykonywania aplikacji

4. Pause – wstrzymanie wykonywania aplikacji z możliwością kontynuowania wykonywania

5. Highlight Execution – podświetlanie danych w czasie wykonania (narzędzie debugowania)

6. Probe – próbnik danych (narzędzie debugowania)

7. Grupa narzędzi debugowania (praca krokowa, punkty zatrzymania)

8. Text Settings – ustawienia wyboru czcionki i stylu tekstu

9. Align Objects – narzędzia wyrównywania obiektów

10. Distribute Objects – narzędzia rozmieszczenia obiektów

11. Reorder – narzędzia grupowania i zmiany kolejności obiektów

12. Clean Up Diagram – narzędzie automatycznego „czyszczenia” diagramu

13. Search – wyszukiwanie

14. Show Context Help Window – włączenie/wyłączenie okna pomocy kontekstowej

Ostatnim stałym elementem głównych okien LabVIEW jest obszar podglądu ikony/złą-cza
(rys. 6). Obszar ten pokazuje nam wygląd ikony VI, jako podprogramu – SubVI – w schema-
cie programu wyższego w hierarchii. Istnieje oczywiście możliwość dowolnej zmiany wyglądu
ikony/złącza. Obszar ten po zmianie trybu wyświetlania ukazuje nam również wygląd złącza, tj.
miejsca, do których można podłączać zmienne wejściowe lub wyjściowe (każdy blok diagramu
posiada określoną ilość pól przyłączeniowych i wyjściowych). LabVIEW nie narzuca żadnych
ograniczeń co do hierarchii (możliwe jest dowolne zagnieżdżanie podprogramów). Obraz hierar-
chii programu uzyskujemy dzięki poleceniu menu View»VI Hierarchy. Warto również zazna-
czyć, iż projektant nie jest ograniczony do jednego ekranu. Zarówno panel sterowania jak i okno
diagramu można przesuwać za pomocą linijek umieszczonych na dole i po prawej stronie ekranu.
Pozwala to na budowę dużych aplikacji, lecz zmniejsza ich przejrzystość.

Rys. 6. Widok ikony/złącza przykładowej aplikacji LabVIEW: z lewej strony widok złącza (terminala po-
łączeniowego), z prawej strony widok ikony
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Stworzony VI można zapisać na dysku w postaci samodzielnego pliku (pliki o rozszerzeniu
*.vi) lub stworzyć bibliotekę programów (pliki o rozszerzeniach *.llb). Operacje związane
z zapisem i odczytem VI znajdują się w menu File.

Rys. 7. Grupa Programming palety Functions

3. Przebieg ćwiczenia

3.1. Otwarcie i uruchomienie przyrządów wirtualnych: Signal Generation
and Processing i Temperature System Demo

3.1.1. Uruchomienie i analiza VI: Signal Generation and Processing

1. Wybrać Start»Wszystkie Programy»National Instruments»LabVIEW 2012»LabVIEW
2012 aby uruchomić program LabVIEW. Pojawi się okno dialogowe LabVIEW.

2. Wybrać Help»Find Examples. Pojawi się okno NI Example Finder, które umożliwia do-
stęp do przykładów LabVIEW.

3. W zakładce Browse, wybrać Browse according to: Task. Następnie wybrać Analyzing
and Processing Signals»Signal Processing»Signal Generation and Processing.vi (wy-
boru dokonuje się poprzez podwójne kliknięcie lewym klawiszem myszy). Panel przyrządu
Signal Generation and Processing zostanie otwarty.
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4. Kliknąć na przycisku Run , znajdującym się na pasku narzędzi, aby uruchomić VI. Ten
przyrząd prezentuje wyniki filtrowania i zmiany kształtu okna filtracji generowanego sygna-
łu. Dodatkowo w przykładzie wyświetlane jest widmo mocy generowanego sygnału. Sygnał
wyjściowy wyświetlany jest na wykresie będącym elementem diagramu:

5. Aby zmienić typ sygnału wejściowego (Input Signal) należy użyć narzędzia Operate Va-
lue . Do wyboru okna (Select Window) i filtra (Select Filter) należy użyć strzałek zwięk-
szania i zmniejszania wartości w kontrolkach. Aby ustalić wymaganą częstotliwość należy
przesunąć kontrolkę Frequency.

6. Nacisnąć przycisk More Info... lub [F5] aby przeczytać więcej na temat funkcji analizy.

7. Nacisnąć przycisk Stop lub [F4] aby zatrzymać VI.

8. Wybrać Window»Show Diagram lub Ctrl-E aby wyświetlić diagram dla VI Signal
Generation and Processing.

9. Wskazać funkcje, struktury i VI znajdujące się na diagramie. Wskazać podstawowe elemen-
ty okna diagramu: pasek menu, obszar roboczy, paletę Functions i pasek narzędzi.

10. Przejść na panel.

11. Zamknąć VI nie zapisując zmian.

3.1.2. Uruchomienie i analiza VI: Temperature System Demo

1. Wybrać Help»Find Examples. Pojawi się okno NI Example Finder, które umożliwia do-
stęp do przykładów LabVIEW.
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2. W zakładce Search, w polu Enter keyword(s) wpisać temperature. Następnie w oknie
wyników po prawej stronie wybrać Temperature System Demo.vi. Panel przyrządu
Temperature System Demo zostanie otwarty (rys. 1).

3. Uruchomić VI.

4. Zmienić stany kontrolek Acquisition i Analysis oraz wartość Update Period. Zaobserwo-
wać zmiany w działaniu VI.

5. Zmienić limity alarmów Low Limit i High Limit. Zaobserwować zmiany w działaniu VI.

6. Zatrzymać VI za pomocą przycisku Abort Execution na pasku narzędzi.

7. Przejść na diagram.

8. Włączyć okno pomocy kontekstowej naciskając CTRL+H lub za pomocą polecenia Help»
Show Context Help.

9. Najechać wskaźnikiem myszy na blok Simulated Temperature.vi oznaczony iko-
ną czerwonego termometru. Zaobserwować zawartość okna pomocy kontekstowej. Naje-
chać wskaźnikiem na inny wybrany blok i zaobserwować zawartość okna pomocy kontek-
stowej.

10. Zamknąć VI bez zapisywania.

11. Zamknąć okno NI Example Finder za pomocą przycisku Close.

3.2. Budowa VI do konwersji wartości temperatury wyrażoną w stopniach Celsju-
sza na wartość temperatury wyrażoną w stopniach Fahrenheita

3.2.1. Budowa panelu

1. Aby utworzyć nowy VI należy wybrać File»New VI lub CTRL+N.

2. Utworzyć kontrolkę Numeric Control. Będzie ona używana do wprowadzania wartości
w ◦C:

(a) Wybrać Numeric Control z palety Controls»Modern»Numeric. Jeśli paleta Con-
trols jest niewidoczna, kliknąć prawym przyciskiem na otwartym obszarze panelu
użytkownika aby ją wyświetlić.

(b) Przenieść kontrolkę na panel i kliknąć aby umieścić ją w wybranym miejscu.

(c) Wpisać Stopnie C wewnątrz etykiety i kliknąć poza etykietą lub przycisk Enter
na pasku narzędzi. Jeśli nazwa nie zostanie wprowadzona od razu, LabVIEW użyje
etykiety domyślnej. Można edytować etykietę za każdym razem używając narzędzia
edycji tekstu.

3. Utworzyć wskaźnik numeryczny Numeric Indicator. Wskaźnik będzie użyty do wyświe-
tlania wartości temperaturyw ◦F:
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(a) Wybrać Numeric Indicator z palety Controls»Modern»Numeric.

(b) Przenieść wskaźnik na panel i kliknąć aby umieścić go w wybranym miejscu.

(c) Wpisać Stopnie F wewnątrz etykiety i kliknąć na zewnątrz etykiety lub kliknąć
przycisk Enter.

(d) Panel powinien wyglądać następująco:

LabVIEW tworzy na diagramie końcówki kontrolek i wskaźników odpowiadające pa-
nelowi. Końcówki reprezentują typy danych kontrolek i wskaźników. Dla przykładu
końcówka DBL reprezentuje typ zmiennoprzecinkowy podwójnej precyzji dla kontro-
lki lub wskaźnika.

3.2.2. Budowa diagramu

Aby utworzyć diagram VI należy wykonać następujące kroki:

1. Przejść na diagram (Window»Show Diagram lub Ctrl+E). Końcówki na diagramie mogą
być wyświetlane jako terminals (końcówki) lub (icons) ikony. Aby zmienić sposób wyświe-
tlania tych obiektów przez LabVIEW należy kliknąć prawym przyciskiem na końcówce
i wybrać View As Icon:

2. Wybrać funkcje Multiply (mnożenie) i Add (dodawanie) z palety Functions»Program-
ming» Numeric i umieścić je na diagramie. Jeśli paleta Functions jest niewidoczna, kliknąć
prawym przyciskiem na wolnym obszarze diagramu by ją wyświetlić.

3. Wybrać Numeric Constant (stała numeryczna) z palety Functions»Programming»Nume-
ric i umieścić dwie z nich na diagramie. Kiedy umieszcza się stałą numeryczną na diagramie
po raz pierwszy jest ona podświetlona, można więc wprowadzić dowolną wartość. Wpro-
wadzić 1.8 dla jednej stałej oraz 32.0 dla drugiej. Jeśli stała została przesunięta zanim
wprowadzono wartość, należy użyć narzędzia edycji tekstu do wprowadzenia wartości.

4. Wykorzystać narzędzie do łączenia (Connect Wire) do połączenia elementów na diagramie
zgodnie ze schematem:
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WSKAZÓWKI:

• Aby połączyć jedną końcówkę z inną, należy użyć narzędzia Connect Wire (ikona
szpulki na palecie narzędzi), kliknąć na pierwszej końcówce, przesunąć narzędzie do
drugiej końcówki i kliknąć na niej.

• Możliwa jest zmiana kierunku łączenia poprzez kliknięcie na diagramie i przeciągnię-
cie kursora w kierunku pionowym. Aby zmienić kierunek łączenia należy nacisnąć
spację.

• Aby zidentyfikować końcówki wejściowe i wyjściowe należy kliknąć prawym przyci-
skiem funkcje Multiply (mnożenie) i Add (dodawanie) i wybrać Visible Items»Ter-
minals z menu kontekstowego by wyświetlić panel połączeń elementu. Po podłączeniu
funkcji wrócić do widoku ikony klikając prawym klawiszem na elemencie i wybiera-
jąc Visible Items»Terminals z menu kontekstowego. Odznaczyć odpowiedni element
menu.

• Po przesunięciu narzędzia łączenia nad port (wejściowy lub wyjściowy), obszar portu
zaczyna migać, wskazując, że kliknięcie spowoduje podłączenie do niego przewodu.
W dymku opisu pojawia się nazwa portu.

• Aby anulować rozpoczętą operację łączenia należy nacisnąć klawisz Esc, kliknąć pra-
wym przyciskiem myszy lub kliknąć na porcie źródłowym.

5. Wyświetlić panel klikając na nim lub wybierając Window»Show Panel.

6. Zachować VI ponieważ będzie on używany w dalszej części ćwiczenia:

(a) Wybrać File»Save.

(b) Przejść do folderu C:\Studenci LV (jeżeli folder nie istnieje należy go utworzyć).

(c) W folderze C:\Studenci LV utworzyć podkatalog o nazwie złożonej z nazwiska
jednego ze studentów sekcji laboratoryjnej. Przejść do utworzonego podkatalogu.

(d) Wpisać Convert C to F.vi w oknie dialogowym.

(e) Kliknąć na przycisku Save.

Ważne: Należy zapisywać wszystkie VI, edytowane w tym ćwiczeniu w C:\Studenci
LV\NAZWISKO.

7. Wprowadzić liczbę do kontrolki Digital Control i uruchomić przyrząd.
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(a) Wybrać narzędzie Operating Value lub narzędzie edycji tekstu Edit Text (ikona litery
A w palecie narzędzi), kliknąć podwójnie na kontrolce Digital Control i wprowadzić
nowa liczbę. Kliknąć Run aby uruchomić VI.

(b) Przetestować działanie VI dla pięciu różnych wartości temperatur wyrażonych w stop-
niach Celsjusza.

8. Wybrać File»Close aby zamknąć Convert C to F.vi.

3.2.3. Tworzenie podprogramu

1. Wybrać File»Open i przejść do C:\Sutdenci LV\NAZWISKO aby otworzyć przyrząd
wirtualny Convert C to F.vi. Pojawi się panel użytkownika.

2. Jeśli wszystkie otwarte VI zostały wcześniej zamknięte, kliknąć przycisk Open Existing
w oknie dialogowym LabVIEW.

3. Kliknąć prawym przyciskiem myszy na ikonie w prawym górnym rogu panelu użytkownika
i wybrać Edit Icon z menu kontekstowego. Pojawi się okienko dialogowe Icon Editor
z załadowaną ikoną domyślną:

4. Wybrać narzędzie Select w lewym dolnym rogu pasku narzędzi po prawej stronie ob-
szaru ikony.

5. Zaznaczyć cały obszar ikony i nacisnąć Del. Spowoduje to usunięcie grafiki z obszaru ikony.

6. Wybrać narzędzie Rectangle . Przeciągając wskaźnikiem myszy od lewego górnego do
prawego dolnego rogu obszaru ikony narysować prostokąt wypełniający cały ten obszar:
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7. Utworzyć ikonę:

(a) Przejść na zakładkę Icon Text.

(b) W polu tekstowym Line 2 Text wprowadzić C, następnie trzy spacje i F. Ustawić
czcionkę (Font) na Small Font, wyrównanie (Alignment) na center i rozmiar (Size)
na 14:

(c) Utworzyć strzałkę pomiędzy literami C i F za pomocą narzędzia Line .

(d) Nacisnąć OK. aby zakończyć edycję ikony. Ikona pojawi się w prawym górnym rogu
panelu i diagramu

8. Kliknąć prawym przyciskiem myszy na panel połączeniowy w prawym górnym rogu panelu
użytkownika i wybrać Patterns z menu kontekstowego aby zdefiniować wzorzec panelu
połączeniowego dla podprogramu:

9. Wybrać wzorzec o jednym wejściu i jednym wyjściu . Obszar panelu połączeniowego i
ikony podprogramu powinien wyglądać następująco:
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10. Przypisać końcówki do kontrolki numerycznej i numerycznego wskaźnika:

(a) Wybrać Help»Show Context Help aby wyświetlić okno Context Help.

(b) Kliknąć na lewej końcówce w panelu połączeń. Narzędzie automatycznie przełączy
się w tryb narzędzia Connect Wire (łączenie), i końcówka zmieni kolor na czarny.

(c) Kliknąć kontrolkę Stopnie C. Lewa końcówka zmieni kolor na pomarańczowy
i pojawi obwódka kontrolki.

(d) Kliknąć na wolnym obszarze panelu użytkownika. Obwódka zniknie, a końcówka
zmieni kolor na kolor reprezentowanego typu danych aby pokazać, że połączenie zo-
stało ustanowione.

(e) Kliknąć na prawą końcówkę na panelu połączeń i na wskaźnik Stopnie F. Prawa
końcówka zmieni kolor na pomarańczowy.

(f) Kliknąć na wolnym obszarze panelu użytkownika. Obie końcówki staną się pomarań-
czowe.

(g) Przesunąć kursor nad panel połączeń. Okno Context Help pokaże, że obie końcówki
są połączone z wartościami zmiennoprzecinkowymi:

11. Wybrać File»Save by zapisać VI ponieważ będzie użyty w dalszym ciągu ćwiczenia.

12. Wybrać File»Close aby zamknąć Convert C to F.vi.

3.2.4. Wstawianie podprogramu do programu wyższego poziomu

1. Utworzyć nowy VI.

2. Przejść na diagram.

3. Z palety Functions wybrać Select a VI. W otwartym oknie wybrać Convert C To
F.vi i umieścić blok na diagramie klikając lewym przyciskiem myszy.

4. Włączyć okno Context Help, przesunąć wskaźnik nad wstawiony blok. Zaobserwować
zmiany w oknie Context Help.

5. Wybrać narzędzie Connect Wire. Przesunąć wskaźnik nad lewą końcówkę (wejście Stopnie
C) wstawionego bloku. Końcówka na diagramie i w oknie Context Help zacznie migać,
zmieniając kolor na czarny.
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6. Z menu kontekstowego (prawy przycisk myszy) wybrać Create»Control. Zostanie utwo-
rzona kontrolka numeryczna Stopnie C, podłączona do wejścia Stopnie C bloku Co-
nvert C To F.

7. Przesunąć wskaźnik nad prawą końcówkę (wyjście Stopnie F) wstawionego bloku. Koń-
cówka na diagramie i w oknie Context Help zacznie migać, zmieniając kolor na czarny.

8. Z menu kontekstowego (prawy przycisk myszy) wybrać Create»Indicator. Zostanie utwo-
rzony wskaźnik numeryczny Stopnie F, podłączony do wyjścia Stopnie F bloku Co-
nvert C To F:

9. Wybrać File»Save by zapisać VI jako Temperature Conversion.vi.

10. Przejść na diagram i uporządkować go, tak, aby kontrolka i wskaźnik znajdowały się blisko
siebie.

11. Przetestować działanie VI dla pięciu różnych wartości temperatur wyrażonych w stopniach
Celsjusza.

12. Wybrać File»Close aby zamknąć Temperature Conversion.vi.

3.3. Taktowanie programowe

3.3.1. Budowa panelu

1. Utworzyć nowy VI.

2. Zbudować następujący panel użytkownika:
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(a) Wybrać poziomy suwak Horizontal Pointer Slide z palety Controls»Numeric Con-
trols i umieścić go na panelu. Suwak będzie używany do zmiany częstości taktowania
programowego.

(b) Wpisać Okres taktowania (ms) wewnątrz etykiety i kliknąć poza nią lub na-
cisnąć przycisk Enter na pasku narzędzi, pokazanym po lewej stronie.

(c) Umieścić Stop Button z palety Controls»Modern»Boolean.

(d) Wybrać Waveform Chart z palety Controls»Modern»Graph i umieścić go na panelu
użytkownika. Wykres (Waveform Chart) będzie wyświetlał dane w czasie rzeczywi-
stym.

(e) Wpisać Historia wartości wewnątrz etykiety i kliknąć poza nią lub nacisnąć
przycisk Enter na pasku narzędzi.

(f) Opisać legendę wykresu Plot 0. Użyć narzędzia Tekst i kliknąć potrójnie Plot 0
na legendzie wykresu. Wpisać Wartość, kliknąć poza etykietą lub nacisnąć przycisk
Enter na pasku narzędzi.

(g) Generator liczb losowych generuje liczby z zakresu od 0 do 1, W dalszej pracy nad
przyrządem generator można zamienić poleceniem odczytu danych (np. z karty po-
miarowej). Użyć narzędzia Tekst, kliknąć podwójnie na 10.0 na osi y, wpisać 1,
i kliknąć poza wykresem lub kliknąć przycisk Enter aby zmienić skalę wykresu.

(h) Zmienić -10.0 na osi y na 0.

(i) Nazwać oś y: Wartość a oś x: Czas (sec).

3.3.2. Tworzenie diagramu

1. Wybrać Window»Show Diagram aby wyświetlić diagram.
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2. Objąć dwie końcówki pętlą While, tak jak pokazano na poniższym diagramie:

(a) Wybrać While Loop z palety Functions>Programming»Structures.

(b) Kliknąć i przeciągnnąć prostokątne zaznaczenie wokół obu końcówek

(c) Użyć narzędzia Position/Size/Select (Wybór) w celu zmiany rozmiarów pętli.

3. Wybrać Random Number (0-1) (generator liczb losowych) z palety Functions»Nume-
ric. Alternatywnie można użyć tego VI jako przyrządu rejestrującego dane z zewnętrznego
czujnika pomiarowego.

4. Połączyć elementy tak jak pokazano na poprzednim diagramie.

5. Zapisać VI jako Use a Loop.vi.

6. Przejść na panel.

7. Uruchomić VI. Część diagramu wewnątrz pętli While wykonuje się dotąd aż warunek za-
trzymania pętli (warunek logiczny) nie będzie spełniony (TRUE). Dla przykładu, dopóki
przycisk STOP nie jest naciśnięty (wartość kontrolki równa FALSE), VI generuje nową
wartość i wyświetla ją na wykresie.

8. Kliknij przycisk STOP aby zatrzymać działanie VI. Warunek ma wartość (TRUE) i pętla
przestaje się wykonywać.

9. Sformatować i dostosować skale na osiach X i Y wykresu:

(a) Kliknąć prawym przyciskiem myszy na wykresie i wybierać Properties z menu kon-
tekstowego. Pojawi się okienko dialogowe.
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(b) Kliknąć zakładkę Scale i wybrać różne style dla osi x i y. Można także wybrać różne
tryby odwzorowania, opcje siatki, współczynniki skali, formaty i precyzje. Zaobser-
wować, że zmiany na wykresie uaktualniane są na bieżąco.

(c) Zaznaczyć wymagane opcje (rys. powyżej) i kliknąć przycisk OK.

10. Kliknąć wykres prawym przyciskiem myszy i wybrać Data Operations»Clear Chart z me-
nu kontekstowego aby wyczyścić bufor wyświetlania i zresetować wykres. Jeśli VI jest uru-
chomiony, można wybrać Clear Chart z menu kontekstowego.

3.3.3. Dodawanie instrukcji taktowania

Kiedy VI jest uruchomiony, pętla While wykonuje się tak szybko jak to możliwe. Aby pobie-
rać dane co ściśle określony przedział czasu, (np. co pół sekundy) należy wykonać następujące
kroki: (utworzyć poniższy diagram):

1. Wstawić Time Delay z palety Functions»Programming»Timing. W oknie dialogowym,
które się pojawi wstawić 0.5. Ta funkcja sprawi, że każda iteracja pętli powtórzy się co pół
sekundy (500 ms).

2. Podzielić opóźnienie w milisekundach przez 1000 aby uzyskać czas w sekundach. Podłą-
czyć wyjście funkcji dzielenia do wejścia Delay Time (s) funkcji Time Delay. Pozwoli to
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na ustawianie prędkości wykonania przez suwak umieszczony na panelu użytkownika.

3. Zapisać VI

4. Uruchomić VI. Wypróbować różne wartości opóźnienia i uruchomić VI ponownie. Zaobser-
wować, jak zmiana wartości opóźnienia wpływa na prędkość generowania i wyświetlania
wartości.

5. Zamknąć VI.

3.3.4. Zadanie do samodzielnego wykonania

1. Na podstawie SubVI do konwersji stopni Celsjusza na stopnie Fahrenheita stworzyć VI
generujący losowo temperaturę w stopniach Celsjusza i Fahrenheita z wykorzystaniem pętli
While z taktowaniem programowym. VI powinien wyświetlać temperaturę w obu skalach
na dwóch wykresach typu Waveform Chart.
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