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Ćwiczenie 1 
 

Wprowadzenie do programu NI LabVIEW Express 7.0 
 

1. Cel ćwiczenia 
 

Celem ćwiczenia jest poznanie aplikacji do akwizycji, wizualizacji i obróbki danych  na 
przykładzie programu LABVIEW firmy National Instruments. 
 
2. Wprowadzenie 
 
2.1 Zastosowanie i budowa programu LabVIEW 

 
 Program LabVIEW jest językiem programowania przeznaczonym do gromadze-
nia i obróbki danych pomiarowych. Z powodzeniem może także służyć jako program do 
wizualizacji i sterowania procesów technologicznych. W odróżnieniu od wielu języków 
programowania tworzenie aplikacji w LabVIEW polega na łączeniu odpowiednich sym-
boli graficznych zastępujących konkretne komendy (program stworzony za pomocą Lab-
VIEW nazywany jest VI - wirtualny instrument). Taki sposób tworzenia programu jest 
bardziej przejrzysty i bardzo ułatwia usuwanie błędów lub wprowadzanie późniejszych 
poprawek.  
 Po uruchomieniu LabVIEW na ekranie widzimy dwa okna: ekran panelu stero-
wania (rys. 2) oraz ekran diagramu (rys. 3). Okno panelu sterowania służy do komunika-
cji użytkownika z programem oraz programu z użytkownikiem. Możemy na nim umiesz-
czać wszelkiego rodzaju przełączniki, przyciski, pokrętła, wskaźniki, okna graficzne, 
wykresy itp., które będą wykorzystywane w tworzonej przez nas aplikacji. Ekran diagra-
mu służy do tworzenia struktury programu. Panel sterowania i ekran diagramu posiadają 
stałe elementy są to: pasek menu (1 na rys.2 i 3), pasek narzędzi (2 na rys.2 i 3 oraz rys. 
4), obszar roboczy (3 na rys.2 i 3) oraz obszar podglądu ikony / złącza (4 na rys.2    i 3). 
Pasek menu panelu sterowania zawiera następujące komendy: 
• File - menu gromadzące komendy operacji na plikach i bibliotekach LabVIEW, 
• Edit - komendy kopiowania, wycinania, modyfikacji standardowych elementów,  
• Operate - grupa gromadząca komendy startu / stopu aplikacji użytkownika oraz usta-

wiania wartości domyślnych elementów, 
• Controls - menu zawierające wszystkie elementy możliwe do umieszczenia na panelu 

sterowania,  
•  Windows - grupa ta zawiera komendy wyświetlania okien diagramu, okien informa-

cyjnych, podglądu schowka, rozmieszczania obiektów na ekranie, 
• Text - menu gromadzące komendy operacji na tekście, 



• Help - okno pomocy. 
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Rys. 1. Okno panelu sterowania przykładowej aplikacji w LabVIEW 

(1 - pasek menu, 2- pasek narzędzi, 3 - obszar roboczy, 4 - wy-
gląd ikony / złącza,  

5 - pasek przewijania) 
 



1
2

3

4

5

5

 
Rys. 2. Okno diagramu przykładowej aplikacji w LabVIEW. 

(1 - pasek menu, 2- pasek narzędzi, 3 - obszar roboczy, 4 - wy-
gląd ikony / złącza, 5 - pasek przewijania) 

 
Pasek menu okna diagramu zawiera grupę Functions zamiast grupy Controls. Wszystkie 
pozostałe menu pozostają bez zmian i służą do wykonywania tych samych poleceń co w 
oknie panelu sterowania. Grupa Functions zawiera wszystkie dostępne komendy (sym-
bole graficzne) języka programowania LabVIEW. Programowanie polega na wybieraniu 
odpowiednich bloków z menu Functions i odpowiednim ich łączeniu za pomocą linii - 
przewodów. Połączenia te mają różny wygląd w zależności od przesyłanych informacji 
(np. cienka linia niebieska oznacza dane numeryczne - liczby całkowite). Bloki funkcjo-
nalne zostały podzielone na 19 grup: 
1. Structs & Constants - bloki pętli (For loop, While loop), wyboru (Case), bloki se-

kwencyjne, bloki stałych (numerycznych, tekstowych itp.), 
2. Arithmetic - bloki operacji matematycznych i logicznych, 
3. Trig & Log - bloki funkcji trygonometrycznych, logarytmicznych, wykładniczych, 
4. Comparison - bloki funkcji porównań (równy, większy, mniejszy, różny od zera itp.), 
5. Conversion - bloki konwersji pomiędzy typami zmiennych, 
6. String - bloki operacji na łańcuchach tekstowych, 
7. Array & Cluster - bloki operacji na tablicach i grupach zmiennych, 
8. File I/O - grupa zawierająca bloki operacji wejścia / wyjścia, 
9. Time & Dialog - bloki okien dialogowych i operacji zegarowych (np. czekaj zadaną 

liczbę milisekund, podaj czas systemowy itp.) 
10. Miscellaneous - różnego rodzaju bloki funkcjonalne służące m.in. do wywoływania 

procedur w języku C, wstrzymywania pracy LabVIEW, operacji na bajtach lub sło-
wach itp., 



11.VI - za pomocą tej grupy możemy do tworzonego programu wstawiać wcześniej 
stworzone aplikacje niższego priorytetu (wywołanie procedur), 

12. ADVANTECH - bloki komunikacji z kartami pomiarowymi firmy Advantech, 
13. Analysis - bloki analizy sygnałów (bloki regresji, bloki filtrów, bloki transformacji 

Fouriera itp.), 
14. DAQ - grupa zawierająca bloki obsługi kart I/O, 
15. Instrument I/O - bloki obsługi portu szeregowego i kart GPIB, 
16. Network - bloki operacji sieciowych i dynamicznej wymiany danych DDE, 
17. Picture - bloki operacji graficznych tj. rysowanie punktów, linii, okręgów itp., 
18. Tutorial - bloki przykładowych procedur (VI), 
19. Utility - bloki obsługi błędów, odczytu / zapisu portów I/O itp. 

 
Pasek narzędzi (rys. 4) jest stałym elementem zarówno dla okna sterowania jak    i 

okna diagramu. Wygląd jego zmienia się w zależności od trybu pracy LabVIEW. Możli-
we są dwa tryby pracy: tryb edycji - edit mode (możliwa jest edycja struktury programu i 
wyglądu panelu sterowania), tryb pracy aplikacji - run mode (LabVIEW znajduje się w 
tym trybie po uruchomieniu aplikacji, możliwe jest oglądanie diagramu bez możliwości 
zmian, aplikacją sterować można tylko z panelu sterowania). Pasek narzędzi składa się z 
następujących ikon - przycisków (oznaczenia jak na rys. 4): 
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Rys. 3. Pasek narzędzi programu LabVIEW 

(a- tryb edycji, b- tryb pracy) 
 
 

1. Run button - przycisk służący do uruchamiania aplikacji. 
2. Mode button - zmiana trybu pracy (tryb edycji lub tryb pracy aplikacji). 
Następne ikony paska narzędzi służą do wyboru specjalnych trybów edycji (wraz z wy-
borem odpowiedniego trybu zmienia się wskaźnik myszy): 
3. Operating tool - operacje na panelu sterowania. 
4. Positioning tool - zmiana rozmiarów obiektów, przenoszenie, kopiowanie itp. 
5. Labeling tool - tworzenie i edycja etykiet tekstowych. 
6. Wiring tool - tworzenie połączeń w panelu diagramu. 
7. Coloring tool - zmiana kolorów tła i obiektów. 
Kolejne ikony paska narzędzi służą do kontroli pracy aplikacji: 
8. Ciągłe uruchamianie programu (praca w pętli). 
9. Ustawianie „pułapek” w programie. 
10. Krokowe wykonywanie programu. 



11. Wykonywanie programu wraz z animacją przesyłania sygnałów na diagramie. 
12. i 13. Tworzenie pliku „historii” działania aplikacji. 
Ostatnim stałym elementem głównych okien LabVIEW jest obszar podglądu ikony / złą-
cza (rys. 5). Obszar ten pokazuje nam wygląd ikony naszego programu (VI) w schemacie 
programu wyższego w hierarchii. Istnieje oczywiście możliwość dowolnej zmiany wy-
glądu ikony / złącza. Obszar ten po zmianie trybu wyświetlania ukazuje nam również 
wygląd złącza, tj. miejsca do których można podłączać zmienne wejściowe lub wyjścio-
we (każdy blok diagramu posiada określoną ilość pól przyłączeniowych i wyjściowych). 
LabVIEW nie narzuca żadnych ograniczeń co do hierarchii programu (możliwe jest do-
wolne zagnieżdżanie procedur). Obraz hierarchii programu uzyskujemy dzięki opcji 
Show VI Hierarchy (menu Windows). Warto również zaznaczyć, iż projektant nie jest 
ograniczony do jednego ekranu. Zarówno panel sterowania jak i okno diagramu można 
przesuwać za pomocą linijek umieszczonych na dole i po prawej stronie ekranu. Pozwala 
to na budowę dużych aplikacji lecz zmniejsza ich przejrzystość.  
 

a b

 
 

Rys. 4. Widok ikony / złącza przykładowej aplikacji LabVIEW. 
Aplikacja ta zapisuje łańcuch znakowy do pliku o podanej nazwie. 

a - widok ikony, b - widok złącza (3 pola wejściowe - przyłączeniowe, 1 pole wyjściowe) 
 
 Stworzoną aplikację VI możemy zapisać na dysk w postaci samo-
dzielnego pliku (pliki o rozszerzeniu *.vi) lub stworzyć bibliotekę progra-
mów (pliki o rozszerzeniach *.llb). Umieszczanie plików VI w bibliotekach 
pozwala nadawać im długie nazwy nawet w środowisku WINDOWS 3.1x. 
 
3. Przebieg ćwiczenia 
 
Część I ćwiczenia obejmuje następujące zagadnienia: 
 

• Uruchomienie i analiza przyrządu wirtualnego Signal Generation and Processing 
VI.  

• Zmiana częstotliwości i typów sygnałów wejściowych i obserwacja zmian zacho-
dzących na wyświetlanym wykresie.  

• Zmiana okna przetwarzania sygnału i opcji filtrów.  
• Zatrzymanie przyrządu wirtualnego. 

 
 
 
 



Otwarcie i uruchomienie przyrządu wirtualnego VI (virtual instrument) 
 

1. Wybierz Start»Programs»National Instruments»LabVIEW 
7.0»LabVIEW by uruchomić program LabVIEW. Pojawi się okno dialogowe 
LabVIEW. 

 
2. Wybierz Help»Find Examples. Okno dialogowe, które się pojawi umożliwia 

dostęp do wszystkich dostępnych przykładów LabVIEW. 
 
3. Na zakładce Browse Tab, wybierz browse according to task. Wybierz Analyz-

ing and Processing Signals, następnie Signal Processing, i Signal Genera-
tion and Processing.vi. Pulpit przyrządu Signal Generation and Processing 
VI zostanie otwarty 

 
Ważne Przykład można załadować klikając na przycisk Open VI i przechodząc do la-
bview\examples\apps\demos.llb\Signal Generation and Processing.vi. 
 
Pulpit (FRONT PANEL) 
 

4. Kliknij na przycisku Run (ikona po lewej stronie) znajdującym się na pasku 
narzędzi, by uruchomić VI. Ten przyrząd prezentuje wyniki filtrowania i 
zmiany kształtu okna filtracji generowanego sygnału. Dodatkowo w przykła-
dzie wyświetlane jest widmo mocy generowanego sygnału. Sygnał wyjściowy 
wyświetlany jest na wykresie będącym elementem pulpitu, jak pokazano na 
poniższym wykresie. 

 
 



5. Użyj narzędzia (ikona po lewejstronie), do zmiany Input Signal (typ sygnału 
wejściowego) i Signal Processing (Przetwarzanie sygnału), użyj strzałek 
zwiększania i zmniejszania wartości w kontrolkach i  przesuń wskaźnik 
Frequency aby ustalić wymaganą częstotliwość. 

 
6. Naciśnij przycisk More Info… lub [F5] aby przeczytać więcej na temat funk-

cji analizy. 
7. Naciśnij przycisk Stop lub [F4] aby zatrzymać przyrząd (VI). 

 
Diagram (Block Diagram) 
 

8. Wybierz Window»Show Diagram lub naciśnij klawisze <Ctrl-E> aby wy-
świetlić diagram dla przyrządu Signal Generation and Processing VI. 

 
(MacOS) Naciśnij <Command-E>. (Sun) Naciśnij <Meta-E>.  
(Linux) Naciśnij <Alt-E> keys. 
 
Okno zawiera kilka podstawowych elementów diagramu, w tym funkcje i struktu-
ry, o które są tematem dalszych części ćwiczenia. 
9. Select Window»Show Panel or press the <Ctrl-E> keys to return to the Front 

Panel. 
10. Zamknij VI nie zapisując zmian 

 
Część II ćwiczenia obejmuje następujące zagadnienia: 

• Przyrząd wirtualny do konwersji stopni Celsjusza na stopnie Fahrenhe-
ita. 

 
Budowa VI 
 
Wykonaj poniższe kroki by utworzyć VI, który pobiera liczbę reprezentującą temperaturę 
w stopniach Celsjusza i konwertuje ją na liczbę reprezentującą temperaturę w stopniach 
Fahrenheita. 
 
Na schematach połączeń, strzałka na końcu ikony myszki pokazuje gdzie kliknąć a liczba 
na strzałce wskazuje ile razy 
 
Front Panel 

1. Wybierz File»New by otworzyć nowy panel użytkownika. 
 
 
 
 

 
2. (Opcjonalne) Wybierz Window»Tile Left and Right aby wyświetlić panel i 

diagram obok siebie. 



3. Utwórz kontrolkę digital control. Będzie ona używana do wprowadzania war-
tości w oC. 

a. Wybierz digital control z palety Controls»Numeric Controls. Jeśli 
paleta Controls jest niewidoczna, kliknij prawym przyciskiem na 
otwartym obszarze panelu użytkownika aby ją wyświetlić. 

b. Przenieś kontrolkę na panel i kliknij aby umieścić ją w wybranym 
miejscu. 

c. Wpisz deg C wewnątrz etykiety i kliknij poza etykietą lub przycisk 
Enter napasku narzędzi. Jeśli od razu nie wprowadzisz nazwy, La-
bVIEW użyje etykiety domyślnej. Możesz edytować etykietę za każ-
dym razem używając narzędzia edycji tekstu. 

4. Tworzenie wskaźnika numerycznego (digital indicator). Wskaźnik będzie 
użyty do wyświetlania vartości w oF. 

a. Wybierz digital indicator z palety Controls»Numeric Indicators. 
b. Przenieś wskaźnik na panel i kliknij aby umieścić go w wybranym 

miejscu. 
c. Wpisz deg F wewnątrz etykiety i kliknij na zewnątrz etykiety lub 

kliknij przycisk Enter. 
LabVIEW tworzy na diagramie końcówki kontrolek i wskaźników odpowia-
dające panelowi. Końcówki reprezentują typy danych kontrolek i wskaźni-
ków. Dla przykładu końcówka DBL reprezentuje typ zmiennoprzecinkowy 
podwójnej precyzji dla kontrolki lub wskaźnika. 

Ważne Końcówki kontrolek mają grubszą ramkę niż końcówki wskaźników. 
 
Block Diagram 

5. Wyświetl diagram klikając na nim lub wybierając Window»Show Diagram. 
 

 
 
Uwaga:  Końcówki na diagramie mogą być wyświetlane jako terminals (końców-
ki) lub (icons) ikony.  Aby zmienić sposób wyświetlania tych obiektów przez  
LabVIEW  kliknij prawym przyciskiem na końcówce i wybierz View As Icon.   
 

 



6. Wybierz funkcje Multiply (mnożenie) i Add (dodawanie) z palety Func-
tions»Numeric i umieść je na diagramie. Jeśli paleta Functions jest niewi-
doczna, kliknij prawym przyciskiem na wolnym obszarze diagramu by ją wy-
świetlić. 

7. Wybierz numeric constant (stała numeryczna) z palety Functions»Numeric  
i umieść dwie z nich na diagramie. Kiedy umieszczasz stałą numeryczną na 
diagramie po raz pierwszy, jest ona podświetlona, możesz więc wprowadzić 
dowolną wartość. Wprowadź 1.8 dla jednej stałej oraz 32.0 dla drugiej. Je-
śli przesunąłeś stałą zanim wprowadziłeś wartość, użyj narzędzia edycji tekstu 
do wprowadzenia wartości. 

8. Wykorzystaj narzędzie do łączenia (Wiring tool) do połączenia elementów na 
diagramie zgodnie z powyższym schematem. 

• By połączyć jedną końcówkę z inną, użyj narzędzia do łączenia (ikona 
szpulki na palecie narzędzi), kliknij na pierwszej końcówce, przesuń 
narzędzie do drugiej końcówki i kliknij na niej, tak jak pokazano na 
poniższym rysunku. Możesz zacząć łączenie od dowolnego elementu. 

 

 
• Możesz zmienić kierunek łączenia klikając na diagramie i przeciągając 

kursor w kierunku pionowym. Naciśnij spację by zmienić kierunek łą-
czenia. 

• Aby zidentyfikować końcówki wejściowe i wyjściowe, kliknij prawym 
przyciskiem funkcje Multiply (mnożenie) i Add (dodawanie) i wybierz 
Visible Items»Terminals z menu kontekstowego by wyświetlić panel 
połączeń elementu. Po podłączeniu funkcji wróć do widoku ikony kli-
kając prawym klawiszem na elemencie i wybierając Visible 
Items»Terminals z menu kontekstowego. Odznacz odpowiedni ele-
ment menu. 

• Kiedy przesuniesz narzędzie łączenia nad port (wejściowy lub wyj-
ściowy), obszar portu zaczyna migać, wskazując, że kliknięcie spowo-
duje podłączenie do niego przewodu. W dymku opisu pojawia się na-
zwa portu. 

• Aby anulować rozpoczętą operację łączenia naciśnij klawisz <Esc>, 
kliknij prawym przyciskiem myszy lub kliknij na porcie źródłowym. 

9. Wyświetl panel użytkownika klikając na nim lub wybierając Window»Show 
Panel. 

10. Zachowaj VI ponieważ będzie on używany w dalszej części ćwiczenia. 
a. Wybierz File»Save. 
b. Przejdź do folderu c:\Studenci. 

Ważne Zapisuj wszystkie VI, edytowane przez ciebie w tym ćwiczeniu w 
c:\Studenci 

c. Wpisz Convert C to F.vi w  oknie dialogowym. 



d. Kliknij na przycisku Save. 
11.  Wprowadź liczbę do kontrolki (digital control) I uruchom przyrząd. 

a. Wybierz narzędzie (Operating tool) lub narzędzie edycji tekstu, kliknij 
podwójnie na kontrolce (digital control) i wprowadź nowa liczbę. 
Kliknij Run by uruchomić VI. 

b. Wypróbuj kilka różnych liczb za każdym razem uruchamiając VI. 
12. Wybierz File»Close by zamknąć Convert C to F VI. 

 
Część III ćwiczenia obejmuje następujące zagadnienia: 

• Tworzenie podprogramu (SubVI) 
 
Panel użytkownika (Front Panel) 

1. Wyberz File»Open i przejdź do c:\Sutdenci aby otworzyć przyrząd wir-
tualny Convert C to F.VI. 
Jeśli zamknąłeś wszystkie otwarte VIs, kliknij przycisk Open… w oknie dia-
logowym LabVIEW. 

Wskazówka Kliknij strzałkę obok przycisku Open… w oknie dialogowym LabVIEW 
aby yświetlić ostatnio twierane pliki takie jak Convert C to F.vi. 

 
Pojawi się następujący panel użytkownika: 
 

 
 

2. Kliknij prawym przyciskiem myszy na ikonie w prawym górnym rogu panelu 
użytkownika i wybierz Edit Icon z menu kontekstowego. Pojawi się okienko 
dialogowe Icon Editor. 

3. Kliknij podwójnie narzędzie Wybór po lewej stronie okienka Icon Editor aby 
wybrać ikonę domyślną. 

4. Naciśnij klawisz <Delete> by usunąć ikonę domyślną. 
5. Podwójnie kliknij na narzędziu prostokąt by narysować ramkę. 
6. Utwórz ikonę jak na poniższym rysunku. 



 
a. Użyj narzędzia Tekst by kliknąć na obszarze. 
b. Wpisz C i F. 
c. Podwójnie kliknij narzędzie Tekst i zmień czcionkę na Small Fonts. 
d. Użyj narzędzie Pióro by utworzyć strzałkę. 

Ważne By narysować linie pionowe lub poziome, podczas przeciągania linii naci-
śnij  klawisz <Shift>. 

e. Użyj narzędzia Wybór i klawiszy kursora by przesunąć utworzony 
tekst i strzałkę. 

f. Wybierz ikonę B&W i 256 Colors w polu Copy from aby utworzyć 
czarno białą ikonę, którą LabVIEW użyje do wydruku, jeśli nie będzie 
możliwości wydruku na kolorowej drukarce. 

g. Kiedy ikona jest ukończona, kliknij przycisk OK by zamnkąć okieno  
Icon Editor. Ikona pojawi się w prawym górnym rogu panelu użyt-
kownika i diagramu. 

7. Kliknij prawym przyciskiem myszy ikonę na panelu użytkownika i wybierz 
Show Connector z menu kontekstowego aby zdefiniować wzorzec panelu po-
łączeniowego dla podprogramu. 
LabVIEW wybierze wzorzec bazując na ilości kontrolek i wskaźników na pa-
nelu użytkownika. Dla przykładu, ten panel posiada dwa elementy kontrolne, 
deg C i deg F, więc LabVIEW wybierze wzorzec panelu z dwoma końców-
kami. 

8. Przypisz końcówki do kontrolki numerycznej i numerycznego wskaźnika. 
a. Wybierz Help»Show Context Help by wyświetlić okno Context 

Help. Przejrzyj każde połączenie w oknie Context Help (jest takie jak 
je utworzyłeś. 

b. Kliknij na lewej końcówce w panelu połaczeń. Narzędzie automatycz-
nie przełączy się w tryb narzędzia Łączenie, i końcówka zmieni kolor 
na czarny. 

c. Kliknij kontrolkę deg C. Lewa końcówka zmieni kolor na pomarań-
czowy i pojawi obwódka kontrolki. 

d. Kliknij na wolnym obszarze panelu użytkownika. Obwódka zniknie, a 
końcówka zmieni kolor na kolor reprezentowanego typu danych aby 
pokazać, że połączenie zostało ustanowione. 



e. Kliknij na prawą końcówkę na panelu połączeń i na wskaźnik deg F. 
Prawa końcówka zmieni kolor na pomarańczowy. 

f. Kliknij na wolnym obszarze panelu użytkownika. Obie końcówki sta-
ną się pomarańczowe. 

g. Przesuń kursor nad panel połączeń. Okno Context Help pokaże, że 
obie końcówki są połączone z wartościami zmiennoprzecinkowymi. 

9. Wybierz File»Save by zapisać VI Ponieważ będzie użyty w dalszym ciągu 
kursu. 

10. Wybierz File»Close by zamknąć Convert C to F VI. 
 

Część III ćwiczenia obejmuje następujące zagadnienia: 
• Zastosowanie pętli while i wykresu waveform chart do budowy VI, 

demonstrującego taktowanie programowe (software timing). 
 
Panel Użytkownika (Front Panel) 

1. Otwórz nowy VI. 
2. Zbuduj następujący panel użytkownika. 
 

 
 

a. Wybierz poziomy suwak (horizontal pointer slide) z palety Contro-
ls»Numeric Controls i umieść go na panelu. Suwak będzie używany do 
zmiany częstości taktowania programowego. 

b. Wpisz okres taktowania (ms) wewnątrz etykiety i kliknij poza nią 
lub naciśnij przycisk Enter na pasku narzędzi, pokazanym po lewej stro-
nie. 

c. Umieść Stop Button z palety Controls»Buttons. 
d. Wybierz waveform chart z palety Controls»Graph Indicators i umieść 

go na panelu użytkownika. Wykres (waveform chart) będzie wyświetlał 
dane w czasie rzeczywistym. 

e. Wpisz Historia wartości wewnątrz etykiety i kliknij poza nią lub 
naciśnij przycisk Enter na pasku narzędzi. 

f. Opisz legendę wykresu Plot 0. Użyj narzędzia Tekst i kliknij potrójnie 
Plot 0 na legendzie wykresu, Wpisz Wartość, kliknij poza etykietą lub 
naciśnij przycisk Enter na pasku narzędzi. 



g. Generator liczb losowych generuje liczby z zakresu od 0 do 1, W dalszej 
pracy nad przyrządem generator można zmienić poleceniem odczytu da-
nych (np. z karty pomiarowej). Użyj narzędzia Tekst, kliknij podwójnie na 
10.0 na osi y, wpisz 1, i kliknij poza wykresem lub kliknij przycisk En-
ter by zmienić skalę wykresu. 

h. Zmień –10.0 na osi y na 0. 
i. Nazwij oś y Wartość a oś x Czas (sec). 

 
Diagram (Block Diagram) 
 

3. Wybierz Window»Show Diagram by wyświetlić diagram. 
 
4. Obejmij dwie końcówki pętlą while, tak jak pokazano na poniższym diagra-

mie. 

 
a. Wybierz While Loop z palety Functions»Execution Control. 
b. Kliknij i przeciągnij prostokątne zaznaczenie wokół obu końcówek 
c. Użyj narzędzia Wybór w celu zmiany rozmiarów pętli. 
 

5. Wybierz Random Number (0-1) (generator liczb losowych) z palety Func-
tions»Arithmetic and Comparison»Numeric. Alternatywnie możesz użyć 
tego VI jako przyrządu rejestrującego dane z zewnętrznego czujnika pomia-
rowego. 

6. Połącz elementy tak jak pokazano na poprzednim diagramie. 
7. Zapisz VI jako Use a Loop.vi. 
8. Wyświetl panel użytkownika wybierając Window»Show Panel. 
9. Uruchom VI. 

Część diagramu wewnątrz pętli while wykonuje się dopóki wyspecyfikowany 
warunek logiczny nie jest prawdziwy (TRUE). Dla przykładu, dopóki przy-
cisk STOP nie jest naciśnięty, VI generuje nową wartosć i wyświetla ją na 
wykresie. 

10. Kliknij przycisk STOP aby zatrzymać pobieranie danych. Warunek ma war-
tość (TRUE) i pętla przestaje się wykonywać. 

11. Sformatuj i dostosuj skale na osiach X i Y wykresu. 



a. Kliknij prawym przyciskiem myszy na wykresie I wybierz Properties 
z menu kontekstowego. Pojawi się okienko dialogowe (poniżej). 

b. Kliknij zakładkę Scale i wybierz różne style dla osi x i y. Możesz tak-
że wybrać różne tryby odwzorowania, opcje siatki, współczynniki ska-
li, formaty i precyzje.  Zauważ, że zmiany na wykresie uaktualniane na 
bieżąco. 

c. Zaznacz wymagane opcje  i kliknij przycisk OK. 
 

 
 

12. Kliknij wykres prawym przyciskiem myszy i wybierz Data Opera-
tions»Clear Chart z menu kontekstowego by wyczyścić bufor wyświetlania I 
zresetować wykres. Jeśli VI jest uruchomiony, możesz wybrać Clear Chart z 
menu kontekstowego. 

 
Dodanie Instrukcji Taktowania 
Kiedy VI jest uruchomiony, pętla while wykonuje się tak szybko jak to możliwe. Wyko-
naj następujące kroki by pobierać dane co ściśle określony przedział czasu, jak na przy-
kład co pół sekundy, (poniższy diagram).  



 
a. Wstaw Time Delay Express VI z palety Functions»Execution Con-

trol. W oknie dialogowym, które się pojawi wstaw 0.5.  Ta funkcja 
sprawi, że każda iteracja pętli powtórzy się co pół sekundy (500 ms). 

b. Podziel opóźnienie w milisekundach przez 1000 aby uzyskać czas w 
sekundach.  Podłącz wyjście funkcji dzielenia do wejścia Delay Time 
(s) funkcji Time Delay Express VI.  Pozwoli to na ustawianie prędko-
ści wykonania przez suwak umieszczony na panelu użytkownika. 

13. Zapisz VI 
14. Uruchom VI. 
15. Wypróbuj różne wartości opóźnienia i uruchom VI ponownie.  Zauważ, jak 

zmiana wartości opóźnienia wpływa na prędkość generowania i wyświetlania 
wartości. 

16. Zamknij VI. 
 
4. Opracowanie sprawozdania 
 

1. Na podstawie podprogramu do konwersji stopni Celsjusza na stopnie Fahrenheita 
napisać przyrząd wirtualny generujący losowo temperaturę w stopniach Celsjusza 
i Fahrenheita z wykorzystaniem pętli while z taktowaniem programowym. 
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